Back to overview
Degraded

Slow response times on US - API observed

Oct 14 at 10:09pm UTC
Affected services
API
Dashboard

Resolved
Oct 15 at 02:15am UTC

API Response times are returning to normal, as well as dashboard loading. We are observing the latency

Updated
Oct 15 at 12:09am UTC

We are working with out cloud provider on mitigating the issue. Updates will be posted on the thread.

Created
Oct 14 at 10:09pm UTC

We are seeing slow response times on the API, the team is looking into it