Back to overview
Degraded

CDN Response times from US dashboard users

Oct 20 at 04:28pm UTC
Affected services
Dashboard
Dashboard

Resolved
Oct 20 at 06:09pm UTC

The CDN issues with the dashboard client has been resolved for customer in the US East region now. We will continue to monitor the situation

Updated
Oct 20 at 04:45pm UTC

This was further confirmed that only customer browsing from the US-East-1 region are affected by the slow loading times of the dashboard.novu.co client. No affects on API requests or notification processing.

Created
Oct 20 at 04:28pm UTC

Our downstream CDN provider is experiencing issues serving traffic from the us east nodes, and can cause elevated response times when trying to load the dashboard.

This only affects Admin Dashboards located in the us-east region. We are monitoring the situation with our CDN provider.