Slow response times observed on US API services
Resolved
Oct 15 at 07:34pm UTC
The slow secondary instance was resolved and query times are back to normal on our API, we are working with our cloud vendor for a full RCA. The incident post mortem is available at: https://www.notion.so/novuhq/Preference-Schema-Indices-Incident-October-14-15-2025-285d03ad838f8024accacb4b589ec277
Affected services
Updated
Oct 15 at 01:25pm UTC
Response times are returned to normal times, except preference endpoints which still experience slow response times in some scenarios. We are performing database operations on the remaining secondary node. And Working with out database vendor on identifying the root cause.
Affected services
Updated
Oct 15 at 11:28am UTC
We are still experiencing high load on the secondary nodes and working to restore their operational metrics
Affected services
Updated
Oct 15 at 11:05am UTC
Inbox endpoints are now back to operational mode, observing the response times. A DB operation has been performed to roll the affected nodes
Affected services
Updated
Oct 15 at 10:53am UTC
Inbox API endpoints are experiencing a downtime
Affected services
Created
Oct 15 at 10:36am UTC
The US API cluster is affected in slow response times and timeouts observed. The team is working on the issue
Affected services